Что нового

Первый скрипт в Scite4AutoIt

ilMarinaio

Новичок
Сообщения
1
Репутация
0
Всем доброго вечера!
Намедни с официального сайта скачал и установил AutoIt самую последнюю версию! Выбрал "скачать все". Все скачалось и установилось без ошибок!
Но, видимо еще AutoIt надо настраивать? Написал первые строки скрипта и не получилось его собрать! И ошибку дает в непонятно каком коде - она не читается!
Вот скрипт:
Код:
#include "Constants.au3"
#include "GUIConstantsEx.au3"
#include "ImageSearch2015.au3"

Local $result = findImage("b:\test.png")

    If $result = false Then
        MsgBox(0, 'Error', "Image was not found on screen.")
    Else
        MouseMove($result[0], $result[1], 10)
        ;MouseClick($MOUSE_CLICK_RIGHT)
    EndIf


Вот результат компиляции:
PT3NXQT.png
Скорее всего чего-то не находит и говорит об этом.
Стало быть, надо кодировки настраивать? Лазить по настройкам AutoIt и искать нужную настройку по тексту? Не представляю даже, как настройка называется.

Тем не менее скрипт отлично собирается из контекстного меню. Получаю exe-шник, который не работает!

RL6sFeJ.png

Все это живет в папке, в которой вот что есть:

j6nEe34.png

Опыта хорошего общения с AutiIt у меня нету. Поэтому я могу только предполагать, почему такую ошибку пишет! Может в dll-ке функции нету, интерфейс поменялся или ImageSearch2015 неправильно грузит либы....
Хотя бы заставить Scite4AutoIt адекватно ошибки сообщать, тогда бы я уже дальше сам бы разбирался, кому чего не хватает!
Может есть какой-нибудь отладчик для AutoIt более менее удобный?
Заранее спасибо!
Сообщение автоматически объединено:

Вот не люблю непонятки! Установил расширение на Visual Studio Code и там собрал проект! И оная софтина мне на русском языке русскими буквами сказала, что именно не так! Почему-то программка при сборке файлика хотела file:///C:/Program Files (x86)/AutoIt3/SciTE/AutoIt3Wrapper/AutoIt3Wrapper.au3.
А у меня почему-то этого враппера нету, хотя я из коробки установил AutoIt и Scite!. Но не суть. Нашел я этот враппер и подсунул по указанному пути. И файлик начал собираться. Но вот ПОЧЕМУ, когда я все замутил на Visual Studio Code, внезапно сама вдруг починилась кодировка в Scite!
sYoS4Z3.png
Мне не нравятся танцы с бубном. Я AutoIT хочу попробовать для автоматизации и мне надо сделать стабильный поиск картинки в окне. А я вместо этого смотрю, как кодировки то работают, то не работают, как то собирается, то не собирается файлик. Врапперы которых нет, пытаются найти...

В связи с этим тогда вопрос: коль с первым вопросом случайно разобрался, остается второй вопрос: имеется ли в природе стабильный отладчик, где есть брэйкпоинты, пошаговая отладка или хотя бы отладка сообщениями в консоль, но чтобы это был не Scite, который непонятно почему самоперенастраивается...
 
Последнее редактирование:

joiner

Модератор
Локальный модератор
Сообщения
3,427
Репутация
597
нужно скачать полный комплект редактора
в самом редакторе есть проверка на ошибки кода
Tools - Sintax Check
По поводу ошибки: "неизвестная функция". В подключаемых библиотеках не найдена функция с указанным именем. Это можно выяснить и до компиляции, если провести проверку на ошибки в редакторе
 

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8,670
Репутация
2,463
Мне не нравятся танцы с бубном
Так для сведения, AutoIt считается наиболее простым вариантом языка программирования, в других языках как раз таки есть много танцев с бубном.
Просто те кто программируют на других, низкоуровных языках, с трудом понимают простоту )).
 

Spray

Новичок
Сообщения
17
Репутация
1
По снимкам вашего экрана видно, что у вас системный раздел имеет букву R. Видимо, один из разработчиков оказался «индусом» и захардкодил для системного раздела с буквой C, как у 95% скриптеров. Думаю, поэтому и не работает, и для решения проблемы надо найти в настройках SciTE ссылку на враппер и заменить C:\ на R:\
Приятных танцев с бубном! А как надоест, попробуйте тот же самый VSCode — там хотя бы не надо танцевать месяцами напролёт, как с SciTE, хватит парочки приседов ;)
 
Верх