Что нового

Не работает одинаковый скрипт поиска картинки _ImageSearch.au3 на одном из компьютеров

agpxyz

Новичок
Сообщения
2
Репутация
0
Добрый день.
Имеется скрипт, в котором используется поиск с помощью _ImageSearch.au3.
Скрипт работает на 3 компьютерах, на всех одинаковая win 10 pro x64, ОЗУ 6-8 Гб.
При этом на core i3 и i5 все работает без проблем, а на AMD ATHLON 740 ошибок нет. но поиск картинки не выполняет.
Не отрабатывает даже скрипт примера, который был вместе с поставкой библиотеки.
Копировать DLL в директории windows пробовал, переносить всю папку с других компов пробовал.

Не знаю куда копать дальше, если есть идеи, готов с удовольствием попробовать.
Подскажите альтернативные библиотеки.
Сообщение автоматически объединено:

Вот этот скрипт заработал, может кому пригодится.
 
Последнее редактирование:

vivernet

Новичок
Сообщения
21
Репутация
3
Почти наверняка что проблема с корректностью работы драйвер видео карты. Если ищите картинку в окне например андроид эмулятора, то тогда можно попробовать переключить режим рендеринга.
 

filautdinov

Знающий
Сообщения
93
Репутация
9
Так же влияет разрешение окна, экрана на котором производится поиск.
 

vivernet

Новичок
Сообщения
21
Репутация
3
Так же влияет разрешение окна, экрана на котором производится поиск.
ну это все таки само собой должно быть понятно, тем более раз на других компах работает, то проблем с пониманием базовых принципов думаю нету.
А вот проблема, что примерно на каждом седьмом компьютере бывают проблемы у этой библиотеки, это в итоге популярная проблема, которую иногда не выходит решить(((

хотя автор этой библиотеке сам на другую давно перешел, но она правда насколько видел, не опубликована в понятном виде, в плане скачать то можно, но вот как ей пользоваться((((
 
Верх