Что нового

[Сеть, интернет] ошибка при при выполнении функции _INetSmtpMailCom

joiner

Модератор
Локальный модератор
Сообщения
3 362
Репутация
586
сам скрипт
Код:
;
;##################################
; Include
;##################################
#Include<file.au3>
;##################################
; Variables
;##################################
$SmtpServer = IniReadSection("set.ini", "smtp-сервер")             ; address for the smtp-server to use - REQUIRED
$FromName = "name" ; name from who the email was sent
$FromAddress = IniReadSection("set.ini", "mail") ; address from where the mail should come
$ToAddress = IniReadSection("set.ini", "tomail")  ; destination address of the email - REQUIRED
$Subject = "Userinfo"                   ; subject from the email - can be anything you want it to be
$Body = "text"                            ; the messagebody from the mail - can be left blank but then you get a blank mail
$AttachFiles = IniReadSection("set.ini", "file")                       ; the file(s) you want to attach seperated with a ; (Semicolon) - leave blank if not needed
$CcAddress = ""       ; address for cc - leave blank if not needed
$BccAddress = ""     ; address for bcc - leave blank if not needed
$Importance = "High"                  ; Send message priority: "High", "Normal", "Low"
$Username = IniReadSection("set.ini", "login")                    ; username for the account used from where the mail gets sent - REQUIRED
$Password = IniReadSection("set.ini", "pass")                 ; password for the account used from where the mail gets sent - REQUIRED
$IPPort = 25                            ; port used for sending the mail
$ssl = 0    ; enables/disables secure socket layer sending - put to 1 if using httpS
                              ; enables/disables secure socket layer sending - put to 1 if using httpS
;~ $IPPort=465                          ; GMAIL port used for sending the mail
;~ $ssl=1                               ; GMAILenables/disables secure socket layer sending - put to 1 if using httpS

;##################################
; Script
;##################################
Global $oMyRet[2]
Global $oMyError = ObjEvent("AutoIt.Error", "MyErrFunc")
Sleep(10000*100)
$rc = _INetSmtpMailCom($SmtpServer[1][1], $FromName, $FromAddress[1][1], $ToAddress[1][1], $Subject, $Body, $AttachFiles[1][1], $CcAddress, $BccAddress, $Importance, $Username[1][1], $Password[1][1], $IPPort, $ssl)
If @error Then
    MsgBox(0, "Error sending message", "Error code:" & @error & "  Description:" & $rc)
EndIf
;
; The UDF
Func _INetSmtpMailCom($s_SmtpServer, $s_FromName, $s_FromAddress, $s_ToAddress, $s_Subject = "", $as_Body = "", $s_AttachFiles = "", $s_CcAddress = "", $s_BccAddress = "", $s_Importance="Normal", $s_Username = "", $s_Password = "", $IPPort = 25, $ssl = 0)
    Local $objEmail = ObjCreate("CDO.Message")
    $objEmail.From = '"' & $s_FromName & '" <' & $s_FromAddress & '>'
    $objEmail.To = $s_ToAddress
    Local $i_Error = 0
    Local $i_Error_desciption = ""
    If $s_CcAddress <> "" Then $objEmail.Cc = $s_CcAddress
    If $s_BccAddress <> "" Then $objEmail.Bcc = $s_BccAddress
    $objEmail.Subject = $s_Subject
    If StringInStr($as_Body, "<") And StringInStr($as_Body, ">") Then
        $objEmail.HTMLBody = $as_Body
    Else
        $objEmail.Textbody = $as_Body & @CRLF
    EndIf
    If $s_AttachFiles <> "" Then
        Local $S_Files2Attach = StringSplit($s_AttachFiles, ";")
        For $x = 1 To $S_Files2Attach[0]
            $S_Files2Attach[$x] = _PathFull($S_Files2Attach[$x])
;~          ConsoleWrite('@@ Debug : $S_Files2Attach[$x] = ' & $S_Files2Attach[$x] & @LF & '>Error code: ' & @error & @LF) ;### Debug Console
            If FileExists($S_Files2Attach[$x]) Then
                ConsoleWrite('+> File attachment added: ' & $S_Files2Attach[$x] & @LF)
                $objEmail.AddAttachment($S_Files2Attach[$x])
            Else
                ConsoleWrite('!> File not found to attach: ' & $S_Files2Attach[$x] & @LF)
                SetError(1)
                Return 0
            EndIf
        Next
    EndIf
    $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendusing") = 2
    $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpserver") = $s_SmtpServer
    If Number($IPPort) = 0 then $IPPort = 25
    $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpserverport") = $IPPort
    ;Authenticated SMTP
    If $s_Username <> "" Then
        $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate") = 1
        $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendusername") = $s_Username
        $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/sendpassword") = $s_Password
    EndIf
    If $ssl Then
        $objEmail.Configuration.Fields.Item ("http://schemas.microsoft.com/cdo/configuration/smtpusessl") = True
    EndIf
    ;Update settings
    $objEmail.Configuration.Fields.Update
    ; Set Email Importance
    Switch $s_Importance
        Case "High"
            $objEmail.Fields.Item ("urn:schemas:mailheader:Importance") = "High"
        Case "Normal"
            $objEmail.Fields.Item ("urn:schemas:mailheader:Importance") = "Normal"
        Case "Low"
            $objEmail.Fields.Item ("urn:schemas:mailheader:Importance") = "Low"
    EndSwitch
    $objEmail.Fields.Update
    ; Sent the Message
    $objEmail.Send
    If @error Then
        SetError(2)
        Return $oMyRet[1]
    EndIf
    $objEmail=""
EndFunc   ;==>_INetSmtpMailCom
;
;
; Com Error Handler
Func MyErrFunc()
    $HexNumber = Hex($oMyError.number, 8)
    $oMyRet[0] = $HexNumber
    $oMyRet[1] = StringStripWS($oMyError.description, 3)
    ConsoleWrite("### COM Error !  Number: " & $HexNumber & "   ScriptLine: " & $oMyError.scriptline & "   Description:" & $oMyRet[1] & @LF)
    SetError(1); something to check for when this function returns
    Return
EndFunc   ;==>MyErrFunc

после до и после компиляции работает нормально. ставлю в автозагрузку(прописываю в реестре). после загрузки системы скрипт срабатывает минут через 16 и выдает ошибку

Код:
AutoIt Error
---------------------------
Line 413  (File "C:\WINDOWS\mail.exe"):


Error: Subscript used with non-Array variable.
---------------------------
ОК   
---------------------------
жму ок. тут же запускаю тот же самый скрипт и все срабатывает через положенное время нормально. в чем проблема?
 
Автор
joiner

joiner

Модератор
Локальный модератор
Сообщения
3 362
Репутация
586
нашел ошибку. в английском не силен, но понял что не было объявлены элементы массива.
получается что нужно так
Код:
func _mail()
Local $ToAddress = IniReadSection("set.ini", "tomail"),$Subject = "Userinfo" ,$Body = "text" ,$AttachFiles = IniReadSection("set.ini", "file"),$CcAddress = ""  ,$BccAddress = "" ,$Importance = "High" ,$Username = IniReadSection("set.ini", "login")  ,$Password = IniReadSection("set.ini", "pass")  ,$IPPort = 25  ,$ssl = 0 
$rc = _INetSmtpMailCom($SmtpServer[1][1], $FromName, $FromAddress[1][1], $ToAddress[1][1], $Subject, $Body, $AttachFiles[1][1], $CcAddress, $BccAddress, $Importance, $Username[1][1], $Password[1][1], $IPPort, $ssl)
endfunc
 
Верх