Что нового

[Ошибки] При добавлении VERSION.

Viktor217

Осваивающий
Сообщения
233
Репутация
31
Здравствуйте, вот здесь http://autoit-script.ru/index.php/topic,2849.msg20885.html#msg20885 я нашёл информация, о том как добавить дополнительную информацию в скрипт, но после добавления данной информации во время компиляции выскакивает ошибка:
Код:
Error: EndUpdateResource: Returncode = 0 - LastError:110:Системе не удается открыть указанное устройство или файл.
Добавлял я следующее:
Код:
#Region
#AutoIt3Wrapper_Res_Language=1049
#AutoIt3Wrapper_Res_FileVersion=1.0.0.0
#AutoIt3Wrapper_Res_Description=Пример использования Version Info в AutoIt
#AutoIt3Wrapper_Res_LegalCopyright=©2010 Yashied
#AutoIt3Wrapper_Res_Comment=Демонстрационная программа
#AutoIt3Wrapper_Res_Field=OriginalFilename|MyProg.exe
#AutoIt3Wrapper_Res_Field=ProductName|Ресурсы в AutoIt
#AutoIt3Wrapper_Res_Field=ProductVersion|1.0
#EndRegion

Без этого кода, ошибок нету...
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
Чем компилируете?
Какая версия AutoIt3Wrapper'а?
Какая версия AutoIt?

P.S

У меня все прекрасно добавляется.
 
Автор
V

Viktor217

Осваивающий
Сообщения
233
Репутация
31
AutoIt3Wrapper GUI to Compile AutoIt3 Script (ver 2.0.1.24)
AutoIt 3.3.6.1

Пробовал тоже самое сделать, но через компилятор, всё равно такая же ошибка)=
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
Хмм... x86 или x64? Да и вообще, какая система?
 
Автор
V

Viktor217

Осваивающий
Сообщения
233
Репутация
31
Windows XP sp3 x86
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
Код:
Error: EndUpdateResource: Returncode = 0 - LastError:110:Системе не удается открыть указанное устройство или файл.
Это ошибка именно AutoIt3Wrapper'а. Я даже и не знаю в чем может быть дело. Попробуйте переустановить AutoIt и SciTE, скачав полную версию здесь.
 
Автор
V

Viktor217

Осваивающий
Сообщения
233
Репутация
31
Переустановил, не помогло)=
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
А как вы компилируете? Попробуйте просто нажать F7 в SciTE. Возможно еще проблема в том, что какие-то программы блокируют компилируемый файл, открывая его для своих нужд. Попробуйте закрыть окно Explorer'а во время компиляции.
 
Автор
V

Viktor217

Осваивающий
Сообщения
233
Репутация
31
Я в основном компилирую через ф7, но бывает и с помощью окошка фрапера. Вполне возможно, что что-то блочит файлы, хотя без этих строчек всё нормально...
 
Верх