Что нового

[Ошибки] Msgbox не отображается после компиляции.

akoulev

Новичок
Сообщения
166
Репутация
2
Уж и не знаю, бага это или фича, но Msgbox:
Код:
MsgBox(0, "String stripped of all CR characters is:", $kulNOCR); Забавный эффект: если не указан таймаут, - в скомпилированном виде отображаться не будет!

не отображается, если запущена скомпилированная версия скрипта. А при запуске .au3 - без проблем.

Характерно, что касается это ТОЛЬКО варианта с неуказанным временем отображения Msgbox-а:

Код:
MsgBox(0, "String stripped of all CR characters is:", $kulNOCR, 2); А так всё работает!
- а так всё работает!

Возможно, разработчики исходили из того, что Msgbox-ы с неуказанным временем отработки - суть сугубо отладочные механизмы, и нечего им тут под ногами болтаться, когда работает скомпилированная программа? Или это, всё ж таки, глюк?

Или это лично у меня такой глюк? (проверено на четырёх машинах: WXP, SP3)

Посик безмолвствует. (с)
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
У меня все отображается как и положено.
 

Garrett

Модератор
Локальный модератор
Сообщения
3 999
Репутация
964
Работает всё на ура.
 

madmasles

Модератор
Глобальный модератор
Сообщения
7 790
Репутация
2 319
akoulev
Ищите причину у себя. Я никогда такого не замечал.
 

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 472
Репутация
2 401
akoulev
Скомпилированный скрипт в студию.
 
Автор
A

akoulev

Новичок
Сообщения
166
Репутация
2
CreatoR сказал(а):
akoulev
Скомпилированный скрипт в студию.
Увы! - он был безжалостно переписан -уже- несколько десятков раз. Теперь я и сам не могу вновь воссоздать упомянутую картину,- но я видел её своими глазами на 4-х (четырёх!) машинах.
Даже нельзя предположить, что скрипт "туда не заходил" - поскольку при проставлении таймаута данное окно начинало появляться. Словом, если кто увидит подобное - не удивляйтесь, но сохраните такие .au3 и .exe для анализа. И для потомков. :-D
 
Верх