Что нового

Не воспренимается символ ^ в параметрах при запуске программы

fidel157

Новичок
Сообщения
2
Репутация
0
Всем привет, помогите новичку. Запускаю скрипт запуска программы с передачей ей параметров,
Run('start_rdp.exe 192.168.4.3 User Password^')
но символ ^ воспринемается как функция, что делать? заранее спасибо.
 

Zaramot

I ♥ AutoIt
Сообщения
1 160
Репутация
658
Re: [Автоматизация] Символ ^

Попробуй один из вариантов:
Код:
Run(@ComSpec & ' /c start start_rdp.exe 192.168.4.3 User Password^', '', @SW_HIDE)


Код:
ShellExecute('start_rdp.exe', '192.168.4.3 User Password^', '', '', @SW_HIDE)


Код:
#include <Process.au3>
_RunDOS('start_rdp.exe 192.168.4.3 User Password^')
 
Автор
F

fidel157

Новичок
Сообщения
2
Репутация
0
Re: [Автоматизация] Символ ^

К сожелению не получается, последний символ "^" так и не воспренимается. Есть ещё какие нибудь решения?
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 713
Re: [Автоматизация] Символ ^

Run('start_rdp.exe 192.168.4.3 User "Password^"')
 

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 473
Репутация
2 403
Re: [Автоматизация] Символ ^

fidel157
Предупреждение За нарушение правил форума (пункт Б.5):
Имя темы должно нести смысловую нагрузку (отражать суть вопроса/проблемы)
Правильно сформулированное название темы привлекает больше внимания, и шансы получить конкретный ответ увеличиваются.


Данные правила могут пополняться локальными правилами раздела.
Как правильно называть темы

"[Автоматизация] Символ ^" - это неприемлемое название темы, переименуйте тему иначе она будет закрыта, а вам возможно будет выдан бан на несколько дней.

С уважением, Администратор форума.
 
Верх