Что нового

Баг TrayItemSetText()

timsky

Осваивающий
Сообщения
93
Репутация
28
ОС: Windows 7 x64 En / XP SP 3 En
AutoIt 3.3.6.0

Элемент меню в трее получает в качестве текста какой-то спецсимвол, который в ХР / 2003 отображается в виде квадратика, а в 7-ке - просто пусто.

Код:
#include <Constants.au3>

TrayItemSetText($TRAY_ITEM_PAUSE, 'Pause')
TrayItemSetText($TRAY_ITEM_EXIT, 'Exit')

MsgBox(0, 'Баг!', 'А теперь кликаем по значку в трее :p ')
 

kaster

Мой Аватар, он лучший самый
Команда форума
Глобальный модератор
Сообщения
4 020
Репутация
622
у меня буква г отображается :smile:
 

Nik_rus

Python The Snake.
Сообщения
214
Репутация
62
wtf, или я что-то не понимаю, но у меня все норм отображается...
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
У меня тоже все нормально.
 

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 472
Репутация
2 401
Yashied [?]
У меня тоже все нормально.
В 3.3.6.0?

Что возввращает это:

Код:
#include <Debug.au3>
ConsoleWrite(_DebugBugReportEnv())


?

у меня так:
Код:
AutoIt:3.3.6.0   (Os:WIN_XP/X86/Service Pack 2   Language:0419 Keyboard:00000409 Cpu:X64)
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
Код:
AutoIt:3.3.4.0   (Os:WIN_XP/X86/Service Pack 2   Language:0409 Keyboard:00000409 Cpu:X64)
 

Yashied

Модератор
Команда форума
Глобальный модератор
Сообщения
5 379
Репутация
2 711
Ну да, поставил 3.3.6.0, попробывал. Действительно есть бага!
 

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 472
Репутация
2 401
timsky молчит, но тикет на багу он уже зарепортил, нужно тут сообщать, а то я хотел сделать, и если бы не имел привычки пользоваться поиском предварительно, то создал бы дубль.
 
Автор
timsky

timsky

Осваивающий
Сообщения
93
Репутация
28
CreatoR
Да, чет забыл здесь отрапортовать :smile:
 
Верх