Что нового

[Баг] Баг MouseGetPos и MouseMove

DANioR

Чайник
Сообщения
3
Репутация
0
Добрый день.
Не знаю ли в тему, может у меня ось специфическая или сборка с багами но есть такая трабла.
Нужно было перетащить мишку в центр экрана. Использовал MouseMove(). В результате мишка ускакала левее и "чуть" ниже, если "чуть" подходит (так на 300 пикселей в низ).

Думал может привязка к активному окну, да нет. Думаю проверю что на выходе у MouseGetPos
(у меня 1920х1080, крестик это где мышка была).
По Y вообще непонятые значения, как бы с умножителем, да X до 1920 не дотягивает(ну ладно, будем считать что боковая панель виновата в 82 пикселя).


Код:
HotKeySet("{F10}","Ex");
While True

$apos=MouseGetPos();
ConsoleWrite("X:" & $apos[0]& " Y:" & $apos[1]& @extended & @CRLF)
Sleep(1000);
WEnd

Func Ex()
	Exit(0);
EndFunc
 

firex

AutoIT Гуру
Сообщения
943
Репутация
203
Код:
HotKeySet("{F10}","Ex");
While True

$apos=MouseGetPos();
ConsoleWrite("X:" & $apos[0]& " Y:" & $apos[1]& " Extended:" & @extended & @CRLF)
Sleep(1000);
WEnd

Func Ex()
    Exit(0);
EndFunc
 
Автор
D

DANioR

Чайник
Сообщения
3
Репутация
0
ок, оставляем
Код:
ConsoleWrite("X:" & $apos[0]& " Y:" & $apos[1] & @CRLF)

мой промах, но все же почему MouseMove не работает.

Сайт, красавчик, отфильтровал то что мои кривые руки не смогли и нашол подобные темы.
Оказалось, что трабла есть и в основном в х64.
У меня версия AutoIt 3.3.14.2, х64.

С чем связана и ли есть фикс или костыль решения (мне как то лень вижуал запускать и писать свое).
OffTopic:
Визуальная проверка: просто бомба!!!
2-е сообщения и я уже его ненавижу)))
 

InnI

AutoIT Гуру
Сообщения
4 209
Репутация
1 114
DANioR
А так?
Код:
$tPoint = DllStructCreate("struct;long X;long Y;endstruct")
$pPoint = DllStructGetPtr($tPoint)
While Sleep(100)
  DllCall("User32.dll", "bool", "GetCursorPos", "ptr", $pPoint)
  ToolTip($tPoint.X & ":" & $tPoint.Y)
WEnd



Добавлено:
Сообщение автоматически объединено:

Код:
Global $X = 1000, $Y = 500
DllCall("User32.dll", "bool", "SetCursorPos", "int", $X, "int", $Y)
 
Автор
D

DANioR

Чайник
Сообщения
3
Репутация
0
что ж модера будут счас ругаться, но выяснилось, что (изначально) функция _BmpSearch выдала ошибочные координаты на экране с чего я сделал поспешные выводы. В общем думаю мне стоит выспаться, а то недосып убил во мне аналитика проблем и сделал паникера.
OffTopic:
Будем искать решение проблемы смещения в _BmpSearch и как туда маску прикрутить
 
Верх