Что нового

AutoIt Path Switcher - Переключение пути к папке AutoIt

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
AutoIt: 3+
Версия: 1.7

Категория: Автоматизация, Система / Реестр

Описание: Этот небольшой скрипт предназначен для переключения между разными версиями (инстанциями/путями) AutoIt'а...
* Очень полезно для исследования новых фич в последней версии AutoIt'a.
* Позволяет дорабатывать ваши скрипты на той версии, для которой они изначально писались.
* Позволяет параллельно разрабатывать два (или более) проекта, один на старой версии, другой на новой.
* Поддерживается мультиязычность GUI-интерфейса. На данный момент имеется Английский (по умолчанию) и Русский перевод - записи хранятся в файле настроек «AutoIt_Path_Switcher.ini».

На заметку:
- Опция «Set Local Compiler (Установить локальный компилятор)» предназначена для использования локальных ресурсов, например можно поместить сам файл *.bin с изменёнными настройками в папку со скриптом, и тогда при компиляций будет использован именно он, также можно поместить иконку (Icon.ico). Для такой компиляций в архиве добавлен скрипт «AutoCompiler.au3», который будет вызван из пункта в контекстном меню au3-файлов (этот пункт добавляется при отметке данной опций).

Файл: AutoIt_Path_Switcher.zip

Снимок:


История версий:
v1.7
+ Добавлен суффикс в виде версии AutoIt к пункту "Запустить скрипт".
* Исправлена проблема связанная с добавлением пункта "Запустить скрипт (x64)" на x86 системе.
* Исправлена проблема связанная с неправильным определением пути к AutoIt версий (из за нового использования AutoIt3Wrapper).
* Исправлена проблема с компиляцией AutoIt_Path_Switcher.exe как x64.

v1.6
* Опция «Запустить скрипт» в контекстном меню оболочки теперь запускает AutoIt3Wrapper.exe (если доступно) вместо AutoIt3.exe.
- Если AutoIt3Wrapper.exe не найден, и найден AutoIt3_x64.exe, то в контекстное меню оболочки добавляется дополнительный пункт.
+ Добавление иконки у компилированной версий.

v1.5
* Исправлена проблема связанная с правами администратора.
* Исправлена проблема с падением скрипта при неправильной загрузке файла конфигурации.

v1.4
+ Совместимость с AutoIt 3.3.6.1.
+ Совместимость с x64.
+ Поддержка AutoIt3Wrapper.
* Исправлена проблема с применением выбранного языка.
* Полировка кода.

v1.3:
* Улучшено присвоение иконки au3-файлам при установке ассоциаций.
+ Добавлена опция обновления иконок в системе (обновления кеша иконок).
+ Добавлена опция открытия файла настроек из главного окна утилиты.
* Полировка кода.

Автор(ы): G.Sandler (CreatoR)
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Обновление:

v1.3:
* Улучшено присвоение иконки au3-файлам при установке ассоциаций.
+ Добавлена опция обновления иконок в системе (обновления кеша иконок).
+ Добавлена опция открытия файла настроек из главного окна утилиты.
* Полировка кода.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Обновление:

v1.4
+ Совместимость с AutoIt 3.3.6.1.
+ Совместимость с x64.
+ Поддержка AutoIt3Wrapper.
* Полировка кода.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Этим вообще кто нибудь кроме меня пользуется?
 

Garrett

Модератор
Локальный модератор
Сообщения
3 999
Репутация
963
CreatoR сказал(а):
Этим вообще кто нибудь кроме меня пользуется?
Я нет. Какой смысл подгонять программы под версии? Autoit пока еще, слава богу, бесплатный :smile:
Я пользуюсь всегда последними версиями.
.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Garrett [?]
Какой смысл подгонять программы под версии?
Я о смысле написал в первом сообщеии:

* Очень полезно для иследования новых фич в последней версии AutoIt'a.
* Позволяет дорабатывать ваши скрипты на той версии, для которой они изначально писались.
* Позволяет паралельно разрабатывать два (или более) проэкта, один на старой версии, другой на новой.
* Поддерживается мультиязычночть GUI-интерфейса. На данный момент имеется Английский (по умолчанию) и Русский перевод - записи хранятся в файле настроек «AutoIt_Path_Switcher.ini».
 

kaster

Мой Аватар, он лучший самый
Команда форума
Глобальный модератор
Сообщения
4 020
Репутация
622
у меня тоже всегда последняя версия :whistle:
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Garrett
Kaster
Скажите, у вас много проектов есть? а есть старые проекты с огромным кодом который ну никак не хочется переделывать под новые версий, тем более что они работают на ура? :laugh:

У меня лично, на все эти вопросы ответ - Да.
 

kaster

Мой Аватар, он лучший самый
Команда форума
Глобальный модератор
Сообщения
4 020
Репутация
622
CreatoR
нет. я использую AutoIt исключительно по назначению - автоматизация малой и средней сложности. если нужно что-то большее, я использую средства более подходящие под нужды :smile:
 

Garrett

Модератор
Локальный модератор
Сообщения
3 999
Репутация
963
CreatoR [?]
Скажите, у вас много проектов есть? а есть старые проекты с огромным кодом который ну никак не хочется переделывать под новые версий
Нет, больших проектов нет! Есть маленькие скрипты для собственных нужд.
Теперь IMHO немного о портации программ на новую версию! Честно сказать любой ЯП должен учитывать такую вещь как совместимость версий, иначе он быстро станет не популярным, особенно если программисты его активно используют.
Ну, к примеру. Написанные мною каталог ссылок на PHP-3, мини CMS и RSS парсер на PHP-4, прекрасно работает и на версии PHP-5, хотя пятая версия глобально изменилась. Кстати за всё время глобально PHP менялся один раз! Разработчики PHP, меняя и совершенствуя свои версии, не меняют уже созданные старые функции, они добавляют новые и совершенствуют старые. Совершенствуя старые, они учитывают принцип работы этих функций и входные/выходные данные в функциях только могут добавляться, но не наоборот и уж тем более не меняют своих характеристик.
Вы правильно подметите, если скажите, что Autoit это не PHP и его скрипты можно скомпилировать в EXE файл! Ну, тогда я вообще не понимаю смысла переписывать скрипты под новую версию Autoit, если в скомпилированном виде они и на старой версии хорошо работают?!

CreatoR если не трудно, приведите пожалуйста пример, случая, когда ваш готовый скрипт было необходимо переписать под новую версию Autoit.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Garrett [?]
приведите пожалуйста пример, случая, когда ваш готовый скрипт было необходимо переписать под новую версию Autoit
UserJS Manager, хотябы для ускорения работы.

не понимаю смысла переписывать скрипты под новую версию Autoit
Так этим самым ты согласен с тем, что всё же нужно переключаться между версиями, иначе как разрабатывать старые скрипты? :smile:
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329

Garrett

Модератор
Локальный модератор
Сообщения
3 999
Репутация
963
CreatoR [?]
Так этим самым ты согласен с тем, что всё же нужно переключаться между версиями, иначе как разрабатывать старые скрипты?
:laugh: поймали за язык!
Нет, я не это имел в виду. Я просто за то чтобы версии работали равно хорошо как со старыми скриптами, так и с новыми.

А то, что я написал
Garrett [?]
не понимаю смысла переписывать скрипты под новую версию Autoit, если в скомпилированном виде они и на старой версии хорошо работают?!
так я имел в виду, что если программа работает на старой версии, пусть себе работает, а новый релиз писать уже под новую версию Autoit`a! Пользователю всё равно, на какой версии работает ваша программа. Кстати могу предположить, что большая часть старого кода будет работать и под новую версию Autoit`a

P.S. Получается так, допустим человек на лет пять назад писал программу, и тут решил модернизировать, добавить пару функций. В итоге ему пришлось бы писать весь код сначала, если бы версии коренным образом претерпевали изменения! Так? Тогда простите :Censored: такой Си?

Видимо я просто ещё не дорос в программирование на Autoit`e до момента острой необходимости смены версий Autoit`a. Нужно подождать, время покажет. :smile:
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Garrett [?]
Я просто за то чтобы версии работали равно хорошо как со старыми скриптами, так и с новыми.
Я тоже, но это не реально, иначе небыло бы такого понятия как обратная совместимость.

если программа работает на старой версии, пусть себе работает, а новый релиз писать уже под новую версию Autoit`a!
Так я же написал:
[?]
есть старые проекты с огромным кодом который ну никак не хочется переделывать под новые версий
[?]
большая часть старого кода будет работать и под новую версию Autoit`a
смотря о каких версиях идёт речь. У меня самые старые проекты держатся на 3.2.8.1, оттуда портировать на 3.3.6.1 у меня не получается, мне будет легче с нуля написать программу под новую версию, а делать этого у меня нет ни времени, ни желания.

P.S
Могу дать исходники от моего UserJS Manager, в котором 8000 строк не включая библиотеки, а также к нему идут плагины, которые тоже написаны под 3.2.8.1, и тоже имеют немало строк. Можешь попробовать переделать для последней версий AutoIt'а, если получится и программа будет работать также как раньше, сделаю тебя сооавтором проекта, в кругу Opera-манов утилита довольно популярная :smile:
 

Garrett

Модератор
Локальный модератор
Сообщения
3 999
Репутация
963
CreatoR [?]
P.SМогу дать исходники от моего UserJS Manager, в котором 8000 строк не включая библиотеки, а также к нему идут плагины, которые тоже написаны под 3.2.8.1, и тоже имеют немало строк. Можешь попробовать переделать для последней версий AutoIt'а, если получится и программа будет работать также как раньше, сделаю тебя сооавтором проекта, в кругу Opera-манов утилита довольно популярная
Спасибо конечно, но я не любитель оперы. :smile:
К тому же разбирать чужой код это дело сложное и кропотливое. Поэтому я пока пас! ;D
 

kaster

Мой Аватар, он лучший самый
Команда форума
Глобальный модератор
Сообщения
4 020
Репутация
622
CreatoR [?]
Я тоже, но это не реально, иначе небыло бы такого понятия как обратная совместимость.
обратная совместимость как раз таки именно в этом и заключается, что код работает при модификации самой среды исполнения. мои программы на С++/C# и python (не считая ветки 3хх, но это уже практически другой язык) работаю исправно с очень давних пор.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Kaster [?]
обратная совместимость как раз таки именно в этом и заключается, что код работает при модификации самой среды исполнения
Но в AutoIt её почти нет, поэтому я и пишу что это не реально.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Обновление...

v1.5
* Исправлена проблема связанная с правами администратора.
* Исправлена проблема с падением скрипта при неправильной загрузке файла конфигурации.
 
Автор
CreatoR

CreatoR

Must AutoIt!
Команда форума
Администратор
Сообщения
8 160
Репутация
2 329
Обновление...

v1.6
* Опция «Запустить скрипт» в контекстном меню оболочки теперь запускает AutoIt3Wrapper.exe (если доступно) вместо AutoIt3.exe.
- Если AutoIt3Wrapper.exe не найден, и найден AutoIt3_x64.exe, то в контекстное меню оболочки добавляется дополнительный пункт.
 

madmasles

Модератор
Глобальный модератор
Сообщения
7 790
Репутация
2 319
CreatoR,
В v1.6 у меня:
на x32 появился дополнительный пункт в меню Запустить скрипт (х64).
в AutoIt_Path_Switcher.ini и в ComboBox вместо выбранной папки, например, E:\Program Files\AutoIt3_381 появляется E:\Program Files\AutoIt3_381\SciTE\AutoIt3Wrapper и, как следствие, в окне: Текущая версия: N/A и Указанная версия: N/A, хотя запуск скриптов идет выбранной версией AutoIt.
При запуске AutoIt_Path_Switcher.exe из скаченного AutoIt_Path_Switcher.zip появляется предупреждение, о том, что ...\AutoIt_Path_Switcher.exe не является приложением Win32.

"Хотелка": добавить в контекстное меню к пункту Запустить скрипт версию AutoIt, например, Запустить скрипт (3.3.8.1).
 
Верх