Автор Тема: [Автоматизация] Autoit не видит форму на странице  (Прочитано 426 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mrPuh [?]

  • Новичок
  • *
  • Сообщений: 15
  • Репутация: 0
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.14.0
Всем привет!
На странице https://shop1476032445738.1688.com/page/offerlist.htm [nofollow] после прогрузки страницы подгружается и выводится форма авторизации.
Ничто ее не находит, пробовал через:
- StringInStr()
- _IEPropertyGet()
- _IEFormGetCollection()
- _IETagNameGetCollection().
У формы id="J_StaticForm", у поля логин input с аттрибутами: name="TPL_username", class="login-text J_UserName", id="TPL_username_1".
При сохранении html-кода в файл - данной формы нет, хотя ставил большую паузу после загрузки страницы и формы.
Впервые с таким сталкиваюсь, хотя по автоматизации IE хороший опыт.
Помогите, пожалуйста!

Русское сообщество AutoIt


 

Похожие темы

  Тема / Автор Ответов Последний ответ
5 Ответов
6630 Просмотров
Последний ответ Сентябрь 22, 2010, 11:17:00
от decadent
9 Ответов
6860 Просмотров
Последний ответ Октябрь 05, 2012, 20:56:13
от madmasles
8 Ответов
4067 Просмотров
Последний ответ Сентябрь 16, 2012, 06:46:00
от AZJIO
1 Ответов
2138 Просмотров
Последний ответ Ноябрь 16, 2012, 19:51:20
от Medic84
1 Ответов
1929 Просмотров
Последний ответ Апрель 05, 2018, 13:32:57
от Crusaderman
10 Ответов
7811 Просмотров
Последний ответ Сентябрь 07, 2015, 16:38:07
от joiner
0 Ответов
5716 Просмотров
Последний ответ Август 13, 2015, 13:43:18
от madmasles
5 Ответов
1779 Просмотров
Последний ответ Сентябрь 03, 2015, 21:49:20
от Kasper
6 Ответов
1835 Просмотров
Последний ответ Февраль 12, 2016, 20:09:38
от InnI
14 Ответов
2587 Просмотров
Последний ответ Март 08, 2017, 01:07:16
от InnI