Автор Тема: вставить длинную формулу в ячейку EXCEL  (Прочитано 249 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grizli [?]

  • Новичок
  • *
  • Сообщений: 43
  • Репутация: 1
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.12.0
Не получается вставить длинную формулу в ячейку EXCEL.
текст формулы-
=ЕСЛИ(B2="c2eb60e4-d86c-41b1-a990-af7dbd8362a3";"Одежда 01";ЕСЛИ(B2="97c2d265-8f29-43ca-b82e-fb8b554664bf";"Одежда 02";ЕСЛИ(B2="1dfc8b0c-6e6e-4c3e-8e23-0ccd1797b74e";"Одежда академ 01";ЕСЛИ(B2="4c901626-1aac-4a11-88cb-5bf4791f363c";"Одежда выпуск 01";ЕСЛИ(B2="3a0f21c8-4f38-4e47-909f-589c910d1b0b";"Одежда выпуск 02";ЕСЛИ(B2="ebaf3d00-6d07-409a-b29b-1b2453795c7c";"Питание академ 01";ЕСЛИ(B2="fd1be7a5-3617-40d2-8efc-8409e711b88b";"Питание академ 02";ЕСЛИ(B2="b66277be-918f-4eee-9d14-7990c1fa04a5";"Питание 01";ЕСЛИ(B2="da9909c6-95e3-4b82-a904-2eec66e2ddd4";"Питание 02";ЕСЛИ(B2="d5e2b94b-4a8b-44ed-852f-25cdd260fd13";"Пособие выпуск 01";ЕСЛИ(B2="e97ad8b3-9100-4e95-a0f2-ce2e3fd07317";"Ежегодный проезд 01";ЕСЛИ(B2="e04a2c26-d0b3-4189-9e59-d2121705c337";"Ежегодный проезд 02";ЕСЛИ(B2="56d529d4-ba9f-46e5-b4a4-bea7703ba845";"Проезд месяц 01";ЕСЛИ(B2="d452bdf0-04d0-4e7c-a573-923fac65e5eb";"Проезд месяц 02";ЕСЛИ(B2="e1dd20f4-0b32-4781-97f0-5c63a497a296";"Одежда академ 02";)))))))))))))))проблема в очень длинной строке? попробовал ее разделить на 3 текстровые переменные, но все-равно в ячейке после вставки пусто.
« Последнее редактирование: Июнь 25, 2018, 02:13:05 от Grizli »

Русское сообщество AutoIt

вставить длинную формулу в ячейку EXCEL
« Отправлен: Июнь 23, 2018, 08:05:01 »

Оффлайн pvnn [?]

  • Осваивающий
  • **
  • Сообщений: 264
  • Репутация: 22
    • Награды
  • Версия AutoIt: 3.3.12.0
Re: вставить длинную формулу в ячейку EXCEL
« Ответ #1, Отправлен: Июнь 25, 2018, 09:28:53 »
Код: AutoIt [Выделить]
 #include <Excel.au3>

 $oExcel = _Excel_Open()
 $oWorkbook = _Excel_BookNew($oExcel)
 Sleep(300)
 $Formula='=ЕСЛИ(B2="c2eb60e4-d86c-41b1-a990-af7dbd8362a3";"Одежда 01";ЕСЛИ(B2="97c2d265-8f29-43ca-b82e-fb8b554664bf";"Одежда 02";ЕСЛИ(B2="1dfc8b0c-6e6e-4c3e-8e23-0ccd1797b74e";"Одежда академ 01";ЕСЛИ(B2="4c901626-1aac-4a11-88cb-5bf4791f363c";"Одежда выпуск 01";ЕСЛИ(B2="3a0f21c8-4f38-4e47-909f-589c910d1b0b";"Одежда выпуск 02";ЕСЛИ(B2="ebaf3d00-6d07-409a-b29b-1b2453795c7c";"Питание академ 01";ЕСЛИ(B2="fd1be7a5-3617-40d2-8efc-8409e711b88b";"Питание академ 02";ЕСЛИ(B2="b66277be-918f-4eee-9d14-7990c1fa04a5";"Питание 01";ЕСЛИ(B2="da9909c6-95e3-4b82-a904-2eec66e2ddd4";"Питание 02";ЕСЛИ(B2="d5e2b94b-4a8b-44ed-852f-25cdd260fd13";"Пособие выпуск 01";ЕСЛИ(B2="e97ad8b3-9100-4e95-a0f2-ce2e3fd07317";"Ежегодный проезд 01";ЕСЛИ(B2="e04a2c26-d0b3-4189-9e59-d2121705c337";"Ежегодный проезд 02";ЕСЛИ(B2="56d529d4-ba9f-46e5-b4a4-bea7703ba845";"Проезд месяц 01";ЕСЛИ(B2="d452bdf0-04d0-4e7c-a573-923fac65e5eb";"Проезд месяц 02";ЕСЛИ(B2="e1dd20f4-0b32-4781-97f0-5c63a497a296";"Одежда академ 02";)))))))))))))))'
 $oWorkbook.ActiveSheet.Cells(2,3).Formula = $Formula
 


Проверил что работает на Office 2013
« Последнее редактирование: Июнь 25, 2018, 09:51:41 от pvnn »

Оффлайн Grizli [?]

  • Новичок
  • *
  • Сообщений: 43

  • Автор темы
  • Репутация: 1
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.12.0
Re: вставить длинную формулу в ячейку EXCEL
« Ответ #2, Отправлен: Июнь 25, 2018, 12:36:02 »
 :rofl:
все работает, спасибо, я главное пробовал такой вариант и уже после неудачи с ним начал мучиться с экранированием кавычек... намудрил такого, что ничего не получилось.
даже не знаю в чем я ошибся, почему у меня такой вариант не получился.

Русское сообщество AutoIt

Re: вставить длинную формулу в ячейку EXCEL
« Ответ #2 Отправлен: Июнь 25, 2018, 12:36:02 »

 

Похожие темы

  Тема / Автор Ответов Последний ответ
7 Ответов
4597 Просмотров
Последний ответ Май 14, 2010, 01:59:28
от dwerf
15 Ответов
12179 Просмотров
Последний ответ Декабрь 13, 2010, 01:15:23
от Ed_Vard
2 Ответов
2668 Просмотров
Последний ответ Сентябрь 16, 2011, 14:09:20
от gregaz
1 Ответов
2778 Просмотров
Последний ответ Ноябрь 13, 2011, 12:58:15
от madmasles
7 Ответов
4377 Просмотров
Последний ответ Июнь 23, 2013, 22:23:47
от PACHOM
2 Ответов
3225 Просмотров
Последний ответ Октябрь 27, 2013, 09:22:42
от madmasles
1 Ответов
1975 Просмотров
Последний ответ Май 30, 2014, 03:03:20
от Garrett
0 Ответов
1058 Просмотров
Последний ответ Ноябрь 04, 2014, 16:10:38
от ibender
0 Ответов
999 Просмотров
Последний ответ Ноябрь 04, 2014, 17:39:28
от madmasles
5 Ответов
1826 Просмотров
Последний ответ Май 11, 2015, 21:48:08
от Pavel