Общий раздел по AutoIt > Баг-репорты и запросы на новые функции

Неисправляемые кракозябры в редакторе

(1/2) > >>

havi2307:
Скрипт писал на старом SciTE. Накатил новый(не помню какой был старый, вроде там было что-то вроде Lite, но такого в сети найти не могу). В коде вместо русских символов появилась вот такая кракозябра:
  (нажмите для показа/скрытия)После File>Encoding>UTF-8 в редакторе появляется возможность писать русские символы и не видеть вопросительные знаки вместо них, но уже написанный код при этом:
  (нажмите для показа/скрытия)
В коде 2300 строк, нервы на пределе, хэлп :o :stars:


InnI:
Откройте в SciTE любой скрипт. В главном меню "Options" выберите пункт "Open Global Options File". В открывшемся файле найдите строку
--- Код: ---code.page=65001
--- Конец кода ---
Замените 65001 на 0. Сохраните изменения, перезапустите SciTE.

havi2307:

--- Цитата: InnI от Ноябрь 16, 2017, 11:19:59 ---Откройте в SciTE любой скрипт. В главном меню "Options" выберите пункт "Open Global Options File". В открывшемся файле найдите строку
--- Код: ---code.page=65001
--- Конец кода ---
Замените 65001 на 0. Сохраните изменения, перезапустите SciTE.

--- Конец цитаты ---
Сделал. Не помогло

InnI:
havi2307  [?]

--- Цитировать ---Не помогло
--- Конец цитаты ---
Тогда попробуйте 1251 вместо нуля.
Также можете попробовать обнулить параметр utf8.auto.check.


--- Цитировать ---После File>Encoding>UTF-8 в редакторе появляется возможность писать русские символы
--- Конец цитаты ---
После этой операции ваш файл сохранится в UTF-8 и, после установки code.page в ноль, вы получите уже другие кракозябры. Другими словами, кодировка скрипта должна совпадать с кодировкой SciTE.


--- Цитировать ---что-то вроде Lite, но такого в сети найти не могу
--- Конец цитаты ---
Lite версия SciTE устанавливается вместе с AutoIt. Её не нужно искать в сети.

Hikari:
Попробуйте открыть в Notepad++ у меня сначала тоже такая проблема была...

Навигация

[0] Главная страница сообщений

[#] Следующая страница

Перейти к полной версии