Автор Тема: Не корректное отображение форума в браузерах Chrome\Mozilla\Opera  (Прочитано 469 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн edger [?]

  • Новичок
  • *
  • Сообщений: 1
  • Репутация: 0
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.14.0
Здравия! Форум отображается нормально только в IE (и его братишке Microsoft edge), в остальных браузерах css форума не подгружается.
Это происходит потому, что IE браузер тянет http версию сайта, а другие браузеры тянут почему-то https версию сайта. В свою очередь, стили определены http версией:

Код: (html5) ссылка:# [nonactive]
  1. < ссылка:http://december.com/html/4/element/link.html [nonactive] rel="stylesheet" type="text/css" href="[b]http[/b]://autoit-script.ru/Themes/default/css/index.css?fin20"/>
  2. < ссылка:http://december.com/html/4/element/link.html [nonactive] rel="stylesheet" type="text/css" href="[b]http[/b]://autoit-script.ru/Themes/default/css/webkit.css"/>

Если заменить на относительный путь -
Код: (html5) ссылка:# [nonactive]
  1. < ссылка:http://december.com/html/4/element/link.html [nonactive] rel="stylesheet" type="text/css" href="/Themes/default/css/index.css?fin20"/>
  2. < ссылка:http://december.com/html/4/element/link.html [nonactive] rel="stylesheet" type="text/css" href="/Themes/default/css/webkit.css"/>
То будет всё прекрасно подтягиваться.
То же самое с javascript.

У вас очень полезный форум, хочется на нём быть)
« Последнее редактирование: Декабрь 26, 2016, 20:47:24 от Garrett »

Русское сообщество AutoIt


Оффлайн Alofa [?]

  • Скриптер
  • ****
  • Сообщений: 861
  • Репутация: 102
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.12.0
OffTopicGarrett
(нажмите для показа/скрытия)
----------------------- Вы думаете, всё так просто? Да, всё просто. Но совсем не так. -----------------------
Альберт Эйнштейн.

Оффлайн Dm666 [?]

  • Осваивающий
  • **
  • Сообщений: 213
  • Репутация: 48
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.8.0
Так все-таки есть ли способ смотреть форум во всей красе используя расово верный FireFox?

Оффлайн ra4o [?]

  • Продвинутый
  • ***
  • Сообщений: 395
  • Репутация: 57
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.12.0

Русское сообщество AutoIt

Re: Не корректное отображение форума в браузерах Chrome\Mozilla\Opera
« Ответ #3 Отправлен: Декабрь 30, 2016, 11:23:22 »

Оффлайн Dm666 [?]

  • Осваивающий
  • **
  • Сообщений: 213
  • Репутация: 48
  • Пол: Мужской
    • Награды
  • Версия AutoIt: 3.3.8.0
Спасибо!
Вариант от Garret с подкручиванием security.mixed_content.block_active_content помог.  :ok:
Форум возвращается в закрепленные вкладки  :)

Русское сообщество AutoIt

Re: Не корректное отображение форума в браузерах Chrome\Mozilla\Opera
« Ответ #4 Отправлен: Декабрь 30, 2016, 17:06:52 »

 

Похожие темы

  Тема / Автор Ответов Последний ответ
90 Ответов
39135 Просмотров
Последний ответ Август 01, 2014, 12:28:58
от k790
2 Ответов
2353 Просмотров
Последний ответ Февраль 05, 2011, 13:29:37
от Garrett
5 Ответов
3281 Просмотров
Последний ответ Май 29, 2014, 11:25:18
от bistriy
6 Ответов
3209 Просмотров
Последний ответ Ноябрь 23, 2011, 13:36:20
от shakur
0 Ответов
1589 Просмотров
Последний ответ Ноябрь 23, 2011, 01:16:30
от CreatoR
3 Ответов
3049 Просмотров
Последний ответ Март 18, 2012, 01:34:03
от Kaster
0 Ответов
1272 Просмотров
Последний ответ Март 17, 2012, 22:39:41
от madmasles
6 Ответов
6011 Просмотров
Последний ответ Октябрь 07, 2012, 18:22:00
от CreatoR
3 Ответов
1030 Просмотров
Последний ответ Июль 02, 2014, 16:01:40
от alex33
4 Ответов
1231 Просмотров
Последний ответ Февраль 19, 2016, 13:58:31
от InnI